Mail delivery issues
Incident Report for gBridge.io
Resolved
gBridge has moved to a different mail service provider. We will continue to watch the rate of delivered mails.
Posted 9 months ago. Jan 12, 2019 - 12:23 CET
Investigating
The quantity of undeliverable/ delayed mails has suddenly risen sharply. Please be patient when waiting for one, while regularly checking your Junk folders.
Registration mails as well as billing messages (Invoices) are affected.
Posted 9 months ago. Jan 11, 2019 - 23:13 CET
This incident affected: Web Dashboard.